Wasabi Account Control Manager Console views for Control Accounts, Sub-Accounts and Invoices not loading

Incident Report for Wasabi Technologies

Postmortem

From 2024-10-31 00:42 UTC to 2024-10-31 10:03 UTC, we experienced an issue where Control Accounts, Sub-Accounts and Invoice data in WACM was not loading properly when attempted to be viewed by the client. Upon investigation by our Engineering Team, it was found that the nodes responsible for fetching and delivering this data were in a bad state. Once the nodes were restored to a functional state, our team started the process of re-indexing the data, which would allow the data to be served via the WACM portal successfully. 

At 10:03 UTC on October 31, 2024, the WACM data was fully available to customers.

Posted Nov 07, 2024 - 15:24 UTC

Resolved

This incident has been resolved.
Posted Oct 31, 2024 - 09:55 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 31, 2024 - 00:44 UTC

Update

While some of the views have been restored, we continue to work to resolve the issue. This page will be updated as more progress is made.
Posted Oct 31, 2024 - 00:34 UTC

Investigating

We are currently investigating this issue and expect to have these views restored shortly.
Posted Oct 30, 2024 - 20:14 UTC
This incident affected: Wasabi Account Control Manager Console.