WACM / Wasabi Account Control API - System Issues

Incident Report for Wasabi Technologies

Postmortem

On 28 May 2025 at 19:00 UTC, our Engineering and Operations Teams began investigating subaccount creation failures occurring within our WACM/WAC API services. These failures resulted in an HTTP 5XX response error when clients requested the creation of a subaccount utilizing the API or WACM UI. Upon investigation, it was found that a recently deployed software update was responsible for these errors from a bug which caused the API to be unable to reach an internal service due to query timeouts. Once the bug was discovered, our Engineering Team adjusted an internal parameter, allowing API requests to succeed properly. On 29 May 2025 at 03:30 UTC, the WACM/WAC API services were returned back to normal operation.

Posted Jun 02, 2025 - 14:17 UTC

Resolved

The WACM/WAC API service is back to normal and we are marking the event as resolved. Once the analysis is completed by our internal team, we will update the status page with the Post Mortem information.
Posted May 29, 2025 - 04:38 UTC

Monitoring

We identified the cause and fixed the issue. The WACM and WAC API are back to normal and no errors should occur now.
We will continue monitoring the System status.
Posted May 29, 2025 - 03:48 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 29, 2025 - 03:31 UTC

Update

We are continuing to investigate this issue.
Posted May 29, 2025 - 03:13 UTC

Investigating

We are currently investigating System errors when users try to use WACM/Wasabi Account Control API to create subaccounts resulting in Internal Error result.
Posted May 29, 2025 - 03:03 UTC
This incident affected: Wasabi Account Control API and Wasabi Account Control Manager Console.