System Errors in AP-NORTHEAST-1

Incident Report for Wasabi Technologies

Postmortem

Between 2026-05-20 17:57 UTC and 2026-05-21 01:44 UTC, a subset of customers operating in the AP-NORTHEAST-1 region experienced intermittent HTTP 5xx errors impacting object storage operations.

The issue was triggered by failures on a portion of the underlying storage hosts, resulting in temporary service instability within the region. The host failures occurred under elevated internal system activity associated with platform health-management operations and concurrent storage reclamation workflows.
Service impact was intermittent throughout the event window.

Wasabi has implemented additional operational safeguards and recovery workflows to accelerate remediation of impacted internal nodes. These enhancements improve recovery efficiency across high-availability infrastructure and further reduce the risk and duration of future service-impacting events.

Posted May 28, 2026 - 00:56 UTC

Resolved

Incident resolved.
Posted May 21, 2026 - 03:24 UTC

Monitoring

The issue was identified and team performed the actions to resolve it.
We are currently monitoring our systems.
Posted May 21, 2026 - 02:03 UTC

Investigating

We are currently investigating System errors. Some customers experiencing HTTP 5XX error responses when interacting with their Wasabi buckets in AP-NORTHEAST-1 region.
Posted May 21, 2026 - 01:37 UTC
This incident affected: AP-Northeast-1 (Tokyo).