Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 09, 2025 - 20:00 UTC
Scheduled
Wasabi Customers,
We are performing network maintenance in US-WEST-1 on Tuesday, 9 September 2025, 20:00 UTC through Wednesday, 10 September 2025, 03:00 UTC (Tuesday, 9 September 2025, 13:00–20:00 PDT). During this time, we will be replacing our current routers with new higher capacity routers and increasing the capacity for our customers. The expected impact for non-Wasabi Direct Connect (WDX) users should be minimal. Some minor clipping may occur as each component is replaced. WDX customers who will have a longer impact will be contacted individually. There is no action that you must take in preparation for this event. We recognize that this may impact your activity and wanted to make you aware of this upcoming event.
If you have any questions or concerns, please don't hesitate to reach out to our support team at support@wasabi.com.
Thank you for your cooperation.
Wasabi Technical Support
Posted Sep 02, 2025 - 19:26 UTC
This scheduled maintenance affected: US-West-1 (Oregon).