Our EU-CENTRAL-2 region is now fully operational, and we will continue to monitor the service. For any questions or concerns, please reach out to our Support Team at support@wasabi.com
Posted Jul 08, 2025 - 17:10 UTC
Update
We are continuing to work on restoring service in the region. Some customers may continue to experience HTTP 5XX error responses when interacting with their Wasabi bucket(s) at this time.
Posted Jul 08, 2025 - 14:26 UTC
Identified
Our Operations Team is working to restore services in the region. Customers may continue to experience HTTP 5XX error responses when interacting with their Wasabi bucket(s) at this time.
Posted Jul 08, 2025 - 13:10 UTC
Investigating
We are currently experiencing system errors in our EU-CENTRAL-2 (Frankfurt) region. Customers may experience elevated HTTP 5XX error responses when interacting with their Wasabi bucket(s). We will update this page as we have more information.