Reserved Capacity Storage Accounts Receiving 'StorageQuotaExceeded' Error Message
Incident Report for Wasabi Technologies
Postmortem

From 2024-01-30 00:30 UTC to 2024-01-30 16:10 UTC, there was an issue experienced by our Reserved Capacity Storage (RCS) customers who had exceeded their purchased storage quota with the error ‘StorageQuotaExceeded’ when attempting to upload data to their Wasabi bucket(s). Any quota imposed on an RCA account is a soft limit and should not have affected the account’s ability to upload data to their bucket(s), however due to a bug in a recently deployed update, our billing subsystem at 00:30 UTC on 2024-01-30 subsequently flagged all RCS accounts that had exceeded their purchased capacity, and imposed a hard limit cap on the account, preventing any PUT API requests. At 15:20 UTC on 2024-01-30, our Billing team isolated the issue, and a fix was starting to be developed. At 15:50 UTC, the fix was deployed to our billing subsystem, and by 16:10 UTC all affected RCS accounts were back to fully operational status.

Posted Feb 08, 2024 - 20:01 UTC

Resolved
The issue affecting some RCS accounts with an incorrect 'StorageQuotaExceeded' error message has been resolved.

The actual times here for the incident were 3AM - 11 AM EST.
Posted Jan 30, 2024 - 17:36 UTC
Investigating
We are currently investigating an issue where our Reserved Capacity Storage (RCS) customers are receiving an incorrect "StorageQuotaExceeded" error message.
Posted Jan 30, 2024 - 15:58 UTC
This incident affected: US-Central-1 (Texas), US-East-1 (N. Virginia), US-East-2 (N. Virginia), US-West-1 (Oregon), CA-Central-1 (Toronto), EU-West-1 (London), EU-West-2 (Paris), EU-Central-1 (Amsterdam), EU-Central-2 (Frankfurt), AP-Northeast-1 (Tokyo), AP-Northeast-2 (Osaka), AP-Southeast-1 (Singapore), AP-Southeast-2 (Sydney), Wasabi Account Control API, Wasabi Account Control Manager Console, and Wasabi Management Console.