WACM Utilization Data updates may be delayed

Incident Report for Wasabi Technologies

Resolved

The WACM Utilization Data updates issue has been resolved. Please contact support@wasabi.com if you continue to see any problem related to this incident.
Posted Aug 20, 2025 - 15:52 UTC

Update

Issues affecting the response time for WACM have been resolved. Data synchronization is in progress and utilization data should be complete this morning.
Posted Aug 19, 2025 - 12:39 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 19, 2025 - 12:37 UTC

Update

Issues affecting the response time for WACM have been resolved. Data synchronization is in progress and utilization data should be complete this morning.
Posted Aug 19, 2025 - 12:31 UTC

Monitoring

The data synchronization job is currently running and is being monitored to ensure that the synchronization finishes properly and is up-to-date within the next 12 - 24 hours. We will update the status page as we get more information.
Posted Aug 18, 2025 - 20:08 UTC

Identified

As a result of a recent database update, Wasabi’s data synchronization is currently delayed.
The system is being managed and monitored to ensure that the data synchronization finishes properly and is up-to-date.

Please report any problems you encounter with the display of Account Utilization data in WACM to support@wasabi.com.
Posted Aug 18, 2025 - 16:12 UTC
This incident affected: Wasabi Account Control Manager Console.