System Errors in US-EAST-1
Incident Report for Wasabi Technologies
Postmortem

From 2024-06-10 18:25 UTC to 2024-06-10 18:43 UTC, we experienced an issue in our US-EAST-1 (Ashburn) vault which resulted in degraded performance in the region. This impacted customer’s ability to send and retrieve data to/from their buckets in the region, and access services such as the Wasabi Web Console and Wasabi Account Control API. At around 17:48 UTC, the Wasabi Operations team began deploying updates in the US-EAST-1 region. After the update was completed and the process of restarting internal services was started, one service failed, causing communication between our client servers and database to fail. Our Operations Team took action by removing the applied configuration of the failed service and redeploying the service. After this action, the internal services came up successfully and communication between our client servers and database was restored, restoring service in the region.

At 18:43 UTC all services in the US-EAST-1 region were operational.

Posted Jun 21, 2024 - 12:53 UTC

Resolved
This incident is now resolved. Please reach out to support@wasabi.com if you continue to see any errors related to this incident.
Posted Jun 11, 2024 - 03:19 UTC
Monitoring
Our Operations Team identified and corrected the cause of the system errors. Performance to the region is restored and we will continue to monitor the region.
Posted Jun 10, 2024 - 19:00 UTC
Investigating
We are currently experiencing system errors in our US-EAST-1 region.
Posted Jun 10, 2024 - 18:33 UTC
This incident affected: US-East-1 (N. Virginia).