System Errors in US-EAST-1

Incident Report for Wasabi Technologies

Resolved

The issue has been resolved.
Earlier today, some customers in our US-EAST-1 region may have experienced elevated latency or errors on storage PUT requests due to an internal infrastructure issue on our backend. Our team identified the cause and applied a fix. Service has been fully restored. We apologize for any inconvenience.
Posted Aug 26, 2026 - 02:37 UTC

Monitoring

Our team has identified the issue and fixed it. At the moment everything is back to normal and we will continue to monitor before we mark this event as resolved.
Posted Aug 26, 2026 - 01:09 UTC

Investigating

We are currently investigating issues happening in US-EAST-1 region that are impacting some of the PUT (Upload) api calls.
Posted Aug 25, 2026 - 23:46 UTC
This incident affected: US-East-1 (N. Virginia).