System Errors Affecting All Regions
Incident Report for Wasabi Technologies
Postmortem

From 2024-06-19 00:57 UTC to 2024-06-19 04:36 UTC, we experienced issues in all Wasabi regions affecting S3, Wasabi Account Control (WAC) API, and Console services. Our WAC API and Console services were affected between 00:57 UTC - 02:45 UTC and 03:55 UTC - 04:36 UTC, while our S3 service was affected between 01:55 UT - 02:45 UTC. 

At 00:57 UTC it was noticed by our Operations Team that there were connection issues between our Console and WAC API services and our global database with no impact to other (S3) services. While debugging these connection issues, it was noted at 1:55 UTC that S3 services were now also affected. After further investigation from the Operations Team, it was seen that our queuing service within the global database had failed, resulting in these services unable to communicate with the database. 

To correct this issue, Operations had to restart both the global database instance, as well as the queuing service to restore connections for the affected services. Once both the database and queuing service had re-initialized at 2:45 UTC, services were restored. 

At 03:55 UTC, it was noticed that the Console and WAC API were beginning to exhibit the same symptoms as before with a loss of connectivity to the database. Upon further investigation from the Operations Team, it was noted that the queuing service had run low on resources. Operations increased available resources to the service and at 04:10 UTC the services were brought back online. At 04:36 UTC it was confirmed that all services were operational.

Posted Jun 25, 2024 - 13:38 UTC

Resolved
This incident is now resolved. Please reach out to support@wasabi.com if you continue to see any errors related to this incident.
Posted Jun 19, 2024 - 06:40 UTC
Monitoring
Our Operations team have been taken actions to resolve the issues. Currently all services are up and we are continuing to monitor them.
Posted Jun 19, 2024 - 05:23 UTC
Identified
We are currently facing issues with logging into Wasabi Management Console and Wasabi Account Control API, our teams are working to resolve it.
Posted Jun 19, 2024 - 04:35 UTC
Monitoring
Our Operations team have identified the issue and actions have been taken to address it. Currently all services are up and we are continuing to monitor them.
Posted Jun 19, 2024 - 03:01 UTC
Update
We are experiencing system errors in all regions.
Posted Jun 19, 2024 - 02:06 UTC
Update
This is also affecting our Wasabi Account Control API. Our Operations Team is investigating this issue.
Posted Jun 19, 2024 - 01:08 UTC
Investigating
We are currently investigating issues with logging into our Web Console.
Posted Jun 19, 2024 - 01:04 UTC
This incident affected: US-Central-1 (Texas), US-East-1 (N. Virginia), US-East-2 (N. Virginia), US-West-1 (Oregon), CA-Central-1 (Toronto), EU-Central-1 (Amsterdam), EU-Central-2 (Frankfurt), EU-West-1 (London), EU-West-2 (Paris), AP-Northeast-1 (Tokyo), AP-Northeast-2 (Osaka), AP-Southeast-1 (Singapore), AP-Southeast-2 (Sydney), Wasabi Account Control API, and Wasabi Management Console.