Wasabi Management Console errors

Incident Report for Wasabi Technologies

Resolved

Management Console Access is restored to Operational Status
Posted Nov 20, 2025 - 04:06 UTC

Monitoring

Our team had identified the issue and the Wasabi Management Console access is back to normal.
We will continue to monitoring the System status.
Posted Nov 20, 2025 - 03:07 UTC

Update

We are continuing to investigate this issue.
Posted Nov 20, 2025 - 02:42 UTC

Investigating

We are investigating issues regarding Wasabi Console access.
Some customers were facing timeout or webpage taking a long time to load.
Posted Nov 20, 2025 - 02:35 UTC
This incident affected: Wasabi Management Console.