Possible performance issues in the US-EAST-1 region
Incident Report for Wasabi Technologies Inc
Resolved
All systems are operating normally. This incident has been resolved.
Posted May 12, 2021 - 23:11 UTC
Update
We are continuing to investigate this issue.
Posted May 12, 2021 - 22:55 UTC
Investigating
We are currently investigating possible performance issues in our US-EAST-1 region.

6:55PM EST Update: Status page updated to correct region.
Posted May 12, 2021 - 22:46 UTC
This incident affected: US-East-1.