System Errors in EU-WEST-3

Incident Report for Wasabi Technologies

Postmortem

On 25 July 2025 from 19:06 UTC to approximately 21:14 UTC, Wasabi's eu-west-3 (London) region experienced a service incident which resulted in elevated HTTP 5XX errors being returned for many request types to the region. The cause for the incident was an internal service failure, which prevented multiple services within the region from being able to successfully communicate across platforms. Due to this failure, our internal proxy service was unable to efficiently direct requests within the region, resulting in a degradation of the service and causing client requests to fail. Wasabi's Engineering and Operations teams worked to systematically restart impacted service hosts beginning at 19:20 UTC through 19:28 UTC. Once the hosts were back online, internal routing issues due to faulty configuration files required the team to manually correct the configurations and apply those to service hosts. By 21:24 UTC, all hosts and services were operating properly, and the region was operational.

Posted Aug 27, 2025 - 14:55 UTC

Resolved

This incident has been resolved.
Posted Jul 25, 2025 - 22:32 UTC

Monitoring

The issue has been corrected by our Operations Team and the EU-WEST-3 region is now fully operational. We will continue to monitor the region
Posted Jul 25, 2025 - 21:26 UTC

Identified

We have identified the problem and our team is currently working to correct it.
Posted Jul 25, 2025 - 20:21 UTC

Investigating

We are currently experiencing system errors in our EU-WEST-3 region. Customers may experience elevated HTTP 5XX error responses when interacting with their Wasabi bucket(s). We will update this page as we have more information.
Posted Jul 25, 2025 - 19:31 UTC
This incident affected: EU-West-3 (London).