Wasabi.com Try Free Sign-up Form Returning Server Error

Incident Report for Wasabi Technologies

Postmortem

From approximately 13:45 to 17:15 UTC, customers using the Free Trial Form Sign Up on Wasabi.com may have been met with a “Server Error” when submitting their request. Due to an error within one of our website modules, a portion of the service was impacted, which prevented the forms from being submitted properly. That error was resolved and the forms are now properly submitted and processed.

Posted May 14, 2025 - 21:31 UTC

Resolved

This issue has been resolved.
Posted May 14, 2025 - 19:04 UTC

Monitoring

We have identified the issue with the sign-up form submission, and have rolled back changes to restore functionality. This issue should be resolved for all users now, please reach out to support@wasabi.com with any remaining questions.
Posted May 14, 2025 - 17:31 UTC

Investigating

The Try Free Sign-up form on wasabi.com is currently returning Server Error responses upon submission. We are investigating this issue and will update the page here when we have more information.
Posted May 14, 2025 - 16:47 UTC
This incident affected: Wasabi.com.