System Errors in US-EAST-1 and US-EAST-2 regions

Incident Report for Wasabi Technologies

Postmortem

On 26 June 2025 from 18:30 UTC to 19:12 UTC, we experienced system errors in our
us-east-1 and us-east-2 regions due to an unplanned data center thermal event. Starting
at 18:30 UTC, our Operations team was notified of a spike in thermal temperature within
several servers within the data centers. Due to the increase in temperature, multiple
storage pools shut down power to the enclosed drives to preserve drive health and data
integrity. Due to the powering down of these drives, several read & write operations
resulted in HTTP 5XX errors.

Upon notification of this thermal event, Wasabi’s Operations Team worked with the data
center team to diagnose and correct the cooling issue and power cycled each impacted
server. Once each server was fully powered up, all services was restored. By 19:12 UTC,
all services were fully operational.

Posted Jul 03, 2025 - 13:14 UTC

Resolved

This incident has been resolved. Please reach out to support@wasabi.com for any further assistance.
Posted Jun 26, 2025 - 20:14 UTC

Monitoring

We have identified and resolved the issue. All affected resources are back in service. We are currently monitoring the status.
If you see any error, please reach out to support@wasabi.com for assistance.
Posted Jun 26, 2025 - 19:24 UTC

Investigating

We are currently investigating system errors in our US-EAST-1 and US-EAST-2 regions. Customers may experience elevated HTTP 5XX error responses when interacting with their Wasabi bucket(s). We will update this page as we have more information.
Posted Jun 26, 2025 - 18:01 UTC
This incident affected: US-East-1 (N. Virginia) and US-East-2 (N. Virginia).