The scheduled maintenance work has been completed.
Posted Jan 15, 2026 - 19:40 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 15, 2026 - 18:00 UTC
Scheduled
Dear Wasabi Customers,
There will be an emergency network repair in the data center for US-EAST-1 on Thursday 15 January 2026 from 18:00-21:00 UTC.
During this maintenance, we expect that there will be no impact to service. We wanted to make you aware of this activity in case there were any unexpected issues.
To stay informed about the progress of this maintenance activity, please subscribe to status.wasabi.com.
If you have any questions or concerns, please don't hesitate to reach out to our support team.
Thank you for your cooperation.
Best regards, Wasabi Technical Support
Posted Jan 14, 2026 - 23:17 UTC
This scheduled maintenance affected: US-East-1 (N. Virginia).