All services are operational and are currently under monitoring.
Posted Feb 06, 2026 - 11:31 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 06, 2026 - 10:12 UTC
Investigating
A power issue at the US-WEST-1 datacenter has been identified which is in the process of being restored. We will update this page as we have more information.